AlmaLinux 9 ffmpeg svt Update Failure

We have seen some AlmaLinux 9 customers report issues with updating due to their ffmpeg and svt packages getting stuck due a ABI mismatch caused by an epel-next change:

dnf update
Last metadata expiration check: 0:03:14 ago on Tue Sep 15 17:33:37 2026.
Error:
 Problem: package ffmpeg-libs-5.1.10-1.el9.x86_64 from @System requires libSvtAv1Enc.so.0()(64bit), but none of the providers can be installed
  - cannot install both svt-av1-libs-2.3.0-2.el9.next.x86_64 from epel-next and svt-av1-libs-0.9.0-1.el9.x86_64 from @System
  - cannot install both svt-av1-libs-2.3.0-2.el9.next.x86_64 from epel-next and svt-av1-libs-0.9.0-1.el9.x86_64 from epel
  - cannot install the best update candidate for package svt-av1-libs-0.9.0-1.el9.x86_64
  - cannot install the best update candidate for package ffmpeg-libs-5.1.10-1.el9.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

To resolve this we recommend removing the packages, updating dnf then running the upgrade again to install the necessary packages: 

dnf remove ffmpeg ffmpeg-devel ffmpeg-libs libavdevice svt-av1-libs

dnf update

su -c "$(curl -sSL http://install.mediacp.net) upgrade"
  • 0 Users Found This Useful
Was this answer helpful?

Related Articles

There is not enough space on this disk to backup the MediaCP and contents

While performing a backup (either automatic or manual) you may encounter the error message below:...

Differences between MB, GB and MiB, GiB

MediaCP uses a digital metric of units when referring to data size. In this case 1 (GB) Gigabyte...

OpenVZ virtualization

During the installation or upgrade of MediaCP you might receive the following notice: ERROR:...

Unable to access MediaCP on port 2020

There are typically only two reasons why the Media Control Panel is inaccessible: The mediacp...

Cannot login to the MediaCP with valid credentials

If you are unable to login to the MediaCP then there could be several reasons: Captcha...